Skip to main content
← All vulnerabilities
CVE-2019-3828GHSA-74VQ-H4Q8-X6JVPYSEC-2019-5

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files out

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.5.15, 2.6.14, 2.7.8
None on Exploit-DB, Metasploit or GitHub

Summary

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Red Hat Ansible

    2.5.15, 2.6.14, 2.7.8

  • ansiblePyPI

    fixed in 2.5.15

  • ansiblePyPI

    From 2.6.0a1 · fixed in 2.6.14

  • ansiblePyPI

    From 2.7.0a1 · fixed in 2.7.8

  • ansiblePyPI

    From 2.5.0 · fixed in 2.5.15; From 2.6.0 · fixed in 2.6.14; From 2.7.0 · fixed in 2.7.8

References 9

GitHub · ansible/ansible

bugzilla.redhat.com

lists.opensuse.org

usn.ubuntu.com

access.redhat.com

packetstormsecurity.com