CVE-2019-3809GHSA-JP4G-R8C9-3534
A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.1.16
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions. The mybackpack functionality allowed setting the URL of badges, when it should be restricted to the Mozilla Open Badges backpack URL. This resulted in the possibility of blind SSRF via requests made by the page.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] moodle
3.1.16
- moodle/moodlePackagist
From 3.1 · fixed in 3.1.16