Skip to main content
← All vulnerabilities
CVE-2019-3808GHSA-4R2P-WPV5-683W

A flaw was found in Moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.6.2, 3.5.4, 3.4.7, 3.1.16
None on Exploit-DB, Metasploit or GitHub

Summary

A flaw was found in Moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The 'manage groups' capability did not have the 'XSS risk' flag assigned to it, but does have that access in certain places. Note that the capability is intended for use by trusted users, and is only assigned to teachers and managers by default.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • [UNKNOWN] moodle

    3.6.2, 3.5.4, 3.4.7, 3.1.16

  • moodle/moodlePackagist

    From 3.6.0 · fixed in 3.6.2

  • moodle/moodlePackagist

    From 3.5.0 · fixed in 3.5.4

  • moodle/moodlePackagist

    From 3.2.0 · fixed in 3.4.7

  • moodle/moodlePackagist

    fixed in 3.1.16

References 3

bugzilla.redhat.com

moodle.org

git.moodle.org