Skip to main content
← All vulnerabilities
CVE-2019-3728

RSA BSAFE Crypto-C Micro Edition versions from 4.0.0.0 before 4.0.5.4 and from 4.1.0 before 4.1.4, RSA BSAFE Micro Edition Suite versions fr

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.5.4, 4.1.4, 4.0.13, 4.4
None on Exploit-DB, Metasploit or GitHub

Summary

RSA BSAFE Crypto-C Micro Edition versions from 4.0.0.0 before 4.0.5.4 and from 4.1.0 before 4.1.4, RSA BSAFE Micro Edition Suite versions from 4.0.0 before 4.0.13 and from 4.1.0 before 4.4 and RSA Crypto-C versions from 6.0.0 through 6.4.* are vulnerable to an out-of-bounds read vulnerability when processing DSA signature. A malicious remote user could potentially exploit this vulnerability to cause a crash in the library of the affected system.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Dell RSA BSAFE Crypto-C Micro Edition

    From 4.0.0.0 · fixed in 4.0.5.4; From 4.1.0 · fixed in 4.1.4

  • Dell RSA BSAFE Micro Edition Suite

    From 4.0.0 · fixed in 4.0.13; From 4.1.0 · fixed in 4.4

  • Dell RSA Crypto-C

    From 6.0.0

References 1

dell.com