CVE-2019-3705
Buffer Overflow Vulnerability
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.92, 2.61.60.60, 3.20.21.20, 3.21.24.22, 3.23.23.23, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Dell EMC iDRAC6 versions prior to 2.92, iDRAC7/iDRAC8 versions prior to 2.61.60.60, and iDRAC9 versions prior to 3.20.21.20, 3.21.24.22, 3.21.26.22 and 3.23.23.23 contain a stack-based buffer overflow vulnerability. An unauthenticated remote attacker may potentially exploit this vulnerability to crash the webserver or execute arbitrary code on the system with privileges of the webserver by sending specially crafted input data to the affected system.
Timeline
- CVE published
- Record last updated
Affected versions
- Dell EMC iDRAC
From 2.92 · fixed in 2.92; From 2.61.60.60 · fixed in 2.61.60.60; From 3.20.21.20 · fixed in 3.20.21.20; From 3.21.24.22 · fixed in 3.21.24.22; From 3.23.23.23 · fixed in 3.23.23.23; From 3.21.26.22 · fixed in 3.21.26.22