pcp: Local privilege escalation from user pcp to root
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.11.9-5.8.1, 4.3.1-3.5.3, 3.11.9-6.14.1, 4.3.1-lp151.2.3.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A Improper Control of Generation of Code vulnerability in the packaging of pcp of SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Module for Development Tools 15-SP1, SUSE Linux Enterprise Module for Open Buildservice Development Tools 15, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP5; openSUSE Leap 15.1 allows the user pcp to run code as root by placing it into /var/log/pcp/configs.sh This issue affects: SUSE Linux Enterprise High Performance Computing 15-ESPOS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise High Performance Computing 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Module for Development Tools 15-SP1 pcp versions prior to 4.3.1-3.5.3. SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server 15-LTSS pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Server for SAP 15 pcp versions prior to 3.11.9-5.8.1. SUSE Linux Enterprise Software Development Kit 12-SP4 pcp versions prior to 3.11.9-6.14.1. SUSE Linux Enterprise Software Development Kit 12-SP5 pcp versions prior to 3.11.9-6.14.1. openSUSE Leap 15.1 pcp versions prior to 4.3.1-lp151.2.3.1.
Timeline
- CVE published
- Record last updated
Affected versions
- SUSE SUSE Linux Enterprise High Performance Computing 15-ESPOS
From pcp · fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise High Performance Computing 15-LTSS
From pcp · fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Module for Development Tools 15
From pcp · fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Module for Development Tools 15-SP1
From pcp · fixed in 4.3.1-3.5.3
- SUSE SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
From pcp · fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Server 15-LTSS
From pcp · fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Server for SAP 15
From pcp · fixed in 3.11.9-5.8.1
- SUSE SUSE Linux Enterprise Software Development Kit 12-SP4
From pcp · fixed in 3.11.9-6.14.1
- SUSE SUSE Linux Enterprise Software Development Kit 12-SP5
From pcp · fixed in 3.11.9-6.14.1
- openSUSE openSUSE Leap 15.1
From pcp · fixed in 4.3.1-lp151.2.3.1