Skip to main content
← All vulnerabilities
CVE-2019-3465GHSA-PQM6-CGWR-X6PF

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.4, 2.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Rob Richards XmlSecLibs

    All versions prior to version 3.0.3

  • robrichards/xmlseclibsPackagist

    From 3.0.0 · fixed in 3.0.4

  • robrichards/xmlseclibsPackagist

    From 1.0.0 · fixed in 2.1.1

References 15

lists.debian.org

seclists.org

debian.org

GitHub · robrichards/xmlseclibs

simplesamlphp.org

lists.fedoraproject.org

tenable.com