Skip to main content
← All vulnerabilities
CVE-2019-25158GHSA-JX6Q-FQ9H-6G7Q

pedroetb tts-api app.js onSpeechDone os command injection

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.0
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • pedroetb tts-api

    2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4

  • tts-apinpm

    fixed in 2.2.0

References 4

vuldb.com

GitHub · pedroetb/tts-api