Skip to main content
← All vulnerabilities
CVE-2019-25028GHSA-Q74R-4XW3-PPX9

Stored cross-site scripting in Grid component in Vaadin 7 and 8

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.7.20, 8.8.5
None on Exploit-DB, Metasploit or GitHub

Summary

Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Vaadin Vaadin

    From 7.4.0

  • Vaadin vaadin-server

    From 7.4.0

  • com.vaadin:vaadin-bomMaven

    From 7.4.0 · fixed in 7.7.20

  • com.vaadin:vaadin-bomMaven

    From 8.0.0 · fixed in 8.8.5

  • com.vaadin:vaadin-serverMaven

    From 7.4.0 · fixed in 7.7.20

  • com.vaadin:vaadin-serverMaven

    From 8.0.0 · fixed in 8.8.5

References 3

vaadin.com

GitHub · vaadin/framework