CVE-2019-2392
$mod can result in undefined behavior
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.6.20, 4.0.20, 4.2.9, 4.4.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries, which use the $mod operator to overflow negative values. This issue affects: MongoDB Inc. MongoDB Server v4.4 versions prior to 4.4.1; v4.2 versions prior to 4.2.9; v4.0 versions prior to 4.0.20; v3.6 versions prior to 3.6.20.
Timeline
- CVE published
- Record last updated
Affected versions
- MongoDB Inc. MongoDB Server
From 3.6 · fixed in 3.6.20; From 4.0 · fixed in 4.0.20; From 4.2 · fixed in 4.2.9; From 4.4 · fixed in 4.4.1