Skip to main content
← All vulnerabilities
CVE-2019-20920GHSA-3CQR-58RM-57F8SNYK-JS-HANDLEBARS-534478

Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.8, 4.5.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • handlebarsnpm

    fixed in 3.0.8

  • handlebarsnpm

    From 4.0.0 · fixed in 4.5.3

References 3

npmjs.com

snyk.io