Skip to main content
← All vulnerabilities
CVE-2019-19919GHSA-W457-6Q6X-CGP9

Versions of handlebars prior to 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.3.0, 3.0.8
1 proof of concept on GitHub

Summary

Versions of handlebars prior to 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution. Templates may alter an Object's __proto__ and __defineGetter__ properties, which may allow an attacker to execute arbitrary code through crafted payloads.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • handlebarsnpm

    From 4.0.0 · fixed in 4.3.0

  • bootstrap-wysihtml5-railsRubyGems

    From 0.3.3.5 · through 0.3.3.8

  • handlebarsnpm

    fixed in 3.0.8

References 3

npmjs.com

tenable.com

GitHub · fazilbaig1/CVE-2019-19919