Skip to main content
← All vulnerabilities
CVE-2019-18900

libzypp stores cookies world readable

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 16.21.2-27.68.1, 16.21.2-2.45.1
None on Exploit-DB, Metasploit or GitHub

Summary

: Incorrect Default Permissions vulnerability in libzypp of SUSE CaaS Platform 3.0, SUSE Linux Enterprise Server 12, SUSE Linux Enterprise Server 15 allowed local attackers to read a cookie store used by libzypp, exposing private cookies. This issue affects: SUSE CaaS Platform 3.0 libzypp versions prior to 16.21.2-27.68.1. SUSE Linux Enterprise Server 12 libzypp versions prior to 16.21.2-2.45.1. SUSE Linux Enterprise Server 15 17.19.0-3.34.1.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • SUSE CaaS Platform 3.0

    From libzypp · fixed in 16.21.2-27.68.1

  • SUSE SUSE Linux Enterprise Server 12

    From libzypp · fixed in 16.21.2-2.45.1

  • SUSE SUSE Linux Enterprise Server 15

    libzypp 17.19.0-3.34.1

References 3

bugzilla.suse.com

lists.opensuse.org

lists.debian.org