CVE-2019-18889GHSA-79GR-58R3-PWM3
An issue was discovered in Symfony 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0 through 4.3.7.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.4.35, 4.2.12, 4.3.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Symfony 3.4.0 through 3.4.34, 4.2.0 through 4.2.11, and 4.3.0 through 4.3.7. Serializing certain cache adapter interfaces could result in remote code injection. This is related to symfony/cache.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
- symfony/cachePackagist
From 3.1.0 · fixed in 3.4.35
- symfony/cachePackagist
From 4.0.0 · fixed in 4.2.12
- symfony/cachePackagist
From 4.3.0 · fixed in 4.3.8
- symfony/symfonyPackagist
From 3.1.0 · fixed in 3.4.35
- symfony/symfonyPackagist
From 4.0.0 · fixed in 4.2.12
- symfony/symfonyPackagist
From 4.3.0 · fixed in 4.3.8